主页>技术知识>详情

使用knife4j请教下几个问题

villain/2022-02-23/100阅读 /0评论
使用knife4j请教下几个问题简介:项目springboot2.4.x 项目只引入了knife4j的依赖 knife4j-spring-boot-starter - 3.0.3 1.访问swagger-ui/index.html

使用knife4j请教下几个问题

项目springboot2.4.x

项目只引入了knife4j的依赖

knife4j-spring-boot-starter - 3.0.3

1.访问swagger-ui/index.html 原生的ui界面不到,yaml里没有springfox的配置,只有knife4j的,是不是就是打不开

2.下载的openapi.json文件中会出现"extensions": { "x-order": "111111" },集成到coding平台的api文档里就无法识别,这个可以去掉吗?


解决方法:

追加一个问题 为啥增加这个 打包运行都可以 功能也能实现禁止debug这些  但是编译就报错了。。。


应该是配置问题吧?我也是swagger+knife4j。完全没有问题

本文用户投稿或网站收集转载,如有侵权请联系本站。